kbys.net
当前位置:首页 >> tomCAt8最低需要什么版本的jDk >>

tomCAt8最低需要什么版本的jDk

7 and later

7 and later(来之官方文档):

比如tomcat7,对应的jdk就是1.7。tomcat8,对应的就是jdk1.8 依次类推

大版本号一般用6.0,已经出现了稳定版了.在大版本号确定的情况下,越新越好. 肯定是有要求的.6.0和7.0是根据新的jdk开发的.更加快速一些

最好还是和Tomcat8配套使用比较好

tomcat9支持:jdk8(含)以下版本; tomcat8支持:jdk7(含)以下版本; tomcat7支持:jdk6(含)以下版本; 你根据自己的环境来选择。

好像tomcat7.0.6x版本是使用的jdk6编写的,7.0.70之后的用的是jdk7,你使用jdk7肯定没问题

大版本号一般用6.0,已经出现了稳定版了.在大版本号确定的情况下,越新越好. 肯定是有要求的.6.0和7.0是根据新的jdk开发的.更加快速一些!

你这个问题有点模糊。 tomcat是个java应用,运行在jdk上,不是吗? tomcat8和java8安装到一起,使用是没问题的。 如果你是问对javaEE中servlet版本的支持的话,就得去官网查了。

明显是class文件不兼容导致的,你用的哪个版本的jdk? 官方有说明的: Tomcat 8.0 requires Java SE 7 or later. Read the RELEASE-NOTES and the RUNNING.txt file in the distribution for more details.

网站首页 | 网站地图
All rights reserved Powered by www.kbys.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com